在发布到 CocoaPods 是如果遇到下面的问题:

Validating podspec
 -> UIMessageBar (1.0.0)
    - ERROR | [iOS] unknown: Encountered an unknown error (Pod::DSLError) during validation.

[!] The spec did not pass validation, due to 1 error.

可以尝试修改 .podspec 文件中类似这样的配置:

spec.source_files     = 'UIMessageBar/**/*'
spec.resource_bundles = {'UIMessageBar' => ['UIMessageBar/Resources/**/*']}

手动指明要包含的文件类型:

spec.source_files     = 'UIMessageBar/**/*.{swift}'
spec.resource_bundles = {'UIMessageBar' => ['UIMessageBar/Resources/**/*.{xib,png}']}